Mined Opinions For API: alfresco

This tab contains all the opinions collected from Stack Overflow about the API. The other tabs present summaries of the opinions using different algorithms.
  • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that.. details
  • and fetch rows in data set table like : CODESNIPPET_JAVA4 .. details
  • But still giving me white page with head titles only, empty cells !!.. details
  • I will talking throw codes line with a few words, In alfresco I need to create a reports using its Workflows APIs that response as JSON, I found the solution for using JSON as a Data Source in this link (this will be good reference to full understand my issue) : URL_http://www.birt-exchange.org/org/devshare/designing-birt-reports/1053 -scripted-data-source-using-json/ [ URL_http://www.birt-exchange.org/org/devshare /designing-birt-reports/1053-scripted-data-source-using-json/] I downloaded the source and I understand how its works, and finally I was having a problem "authentication issue" and solved it by editing source file 'JSONParser.java', anyway I have another problem now, I have the following code in Java thats working: CODESNIPPET_JAVA1 .. details
  • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET_JAVA3 .. details
  • Everything else works fine (pngs, text, html, GET requests,even authentication).. details
  • If I do a file POST however, the Alfresco server receives the file correctly and sends back a JSON response, but this time the response causes the browser to prompt for a download instead of the letting Javascript process the callback.. details
  • In both GET and POST responses the Content-Type is "application/json;charset=UTF-8" Many thanks for any responses.. details
  • I'd check your classpath, and ensure you only have one copy of each of the jars - my hunch is you may have both old and new copies of at least one and that's confusing it.. details
  • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4.0" and put all as external jars on eclipse for my project, and copied it to WEB-INF/lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .... details
  • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4.0" and put all as external jars on eclipse for my project, and copied it to WEB-INF/lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .... details
  • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET_JAVA5 .. details
  • Really I don't know what the problem is, and how to solve, if anybody have any idea for It, I spent about 1 week on it with no solution ... .. details
  • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET_JAVA5 .. details
Summaries the opinions about alfresco using topic modeling.
  • 0. response scripted download authentication birt post load understand report jsonparser: 8
    • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that.. details
    • I will talking throw codes line with a few words, In alfresco I need to create a reports using its Workflows APIs that response as JSON, I found the solution for using JSON as a Data Source in this link (this will be good reference to full understand my issue) : -scripted-data-source-using-json/ [ /designing-birt-reports/1053-scripted-data-source-using-json/ I downloaded the source and I understand how its works, and finally I was having a problem "authentication issue" and solved it by editing source file 'JSONParser.java', anyway I have another problem now, I have the following code in Java thats working: CODESNIPPET .. details
    • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET .. details
    • and fetch rows in data set table like : CODESNIPPET .. details
    • But still giving me white page with head titles only, empty cells !!.. details
    • In both GET and POST responses the Content-Type is "application/json;charset=UTF-8" Many thanks for any responses.. details
    • If I do a file POST however, the Alfresco server receives the file correctly and sends back a JSON response, but this time the response causes the browser to prompt for a download instead of the letting Javascript process the callback.. details
    • Everything else works fine (pngs, text, html, GET requests,even authentication).. details
  • 0. copy exception birt integrate upload find solution solve external spend: 4
    • I'd check your classpath, and ensure you only have one copy of each of the jars - my hunch is you may have both old and new copies of at least one and that's confusing it.. details
    • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4.0" and put all as external jars on eclipse for my project, and copied it to WEB-INF/lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .... details
    • Really I don't know what the problem is, and how to solve, if anybody have any idea for It, I spent about 1 week on it with no solution ... .. details
    • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET .. details
Summaries of the opinions about alfresco using three algorithms (Textrank, Lexrank and Luhn) adopted from extractive summarization. Each algorithm was used once for the positive opinions and once for the negative opinions.
  • If I do a file POST however, the Alfresco server receives the file correctly and sends back a JSON response, but this time the response causes the browser to prompt for a download instead of the letting Javascript process the callback .
  • Everything else works fine (pngs, text, html, GET requests,even authentication) .
  • In both GET and POST responses the Content Type is "application json;charset=UTF 8" Many thanks for any responses .
  • I will talking throw codes line with a few words, In alfresco I need to create a reports using its Workflows APIs that response as JSON, I found the solution for using JSON as a Data Source in this link (this will be good reference to full understand my issue) : scripted data source using json designing birt reports 1053 scripted data source using json I downloaded the source and I understand how its works, and finally I was having a problem "authentication issue" and solved it by editing source file 'JSONParser java', anyway I have another problem now, I have the following code in Java thats working: CODESNIPPET JAVA1 .
  • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET JAVA3 .
  • and fetch rows in data set table like : CODESNIPPET JAVA4 .
  • But still giving me white page with head titles only, empty cells !!
  • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that .
  • If I do a file POST however, the Alfresco server receives the file correctly and sends back a JSON response, but this time the response causes the browser to prompt for a download instead of the letting Javascript process the callback .
  • Everything else works fine (pngs, text, html, GET requests,even authentication) .
  • In both GET and POST responses the Content Type is "application json;charset=UTF 8" Many thanks for any responses .
  • I will talking throw codes line with a few words, In alfresco I need to create a reports using its Workflows APIs that response as JSON, I found the solution for using JSON as a Data Source in this link (this will be good reference to full understand my issue) : scripted data source using json designing birt reports 1053 scripted data source using json I downloaded the source and I understand how its works, and finally I was having a problem "authentication issue" and solved it by editing source file 'JSONParser java', anyway I have another problem now, I have the following code in Java thats working: CODESNIPPET JAVA1 .
  • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET JAVA3 .
  • and fetch rows in data set table like : CODESNIPPET JAVA4 .
  • But still giving me white page with head titles only, empty cells !!
  • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that .
  • If I do a file POST however, the Alfresco server receives the file correctly and sends back a JSON response, but this time the response causes the browser to prompt for a download instead of the letting Javascript process the callback .
  • Everything else works fine (pngs, text, html, GET requests,even authentication) .
  • In both GET and POST responses the Content Type is "application json;charset=UTF 8" Many thanks for any responses .
  • I will talking throw codes line with a few words, In alfresco I need to create a reports using its Workflows APIs that response as JSON, I found the solution for using JSON as a Data Source in this link (this will be good reference to full understand my issue) : scripted data source using json designing birt reports 1053 scripted data source using json I downloaded the source and I understand how its works, and finally I was having a problem "authentication issue" and solved it by editing source file 'JSONParser java', anyway I have another problem now, I have the following code in Java thats working: CODESNIPPET JAVA1 .
  • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET JAVA3 .
  • and fetch rows in data set table like : CODESNIPPET JAVA4 .
  • But still giving me white page with head titles only, empty cells !!
  • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that .
  • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET JAVA5 .
  • Really I don't know what the problem is, and how to solve, if anybody have any idea for It, I spent about 1 week on it with no solution .
  • I'd check your classpath, and ensure you only have one copy of each of the jars my hunch is you may have both old and new copies of at least one and that's confusing it .
  • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4 0" and put all as external jars on eclipse for my project, and copied it to WEB INF lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .
  • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET JAVA5 .
  • Really I don't know what the problem is, and how to solve, if anybody have any idea for It, I spent about 1 week on it with no solution .
  • I'd check your classpath, and ensure you only have one copy of each of the jars my hunch is you may have both old and new copies of at least one and that's confusing it .
  • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4 0" and put all as external jars on eclipse for my project, and copied it to WEB INF lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .
  • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET JAVA5 .
  • Really I don't know what the problem is, and how to solve, if anybody have any idea for It, I spent about 1 week on it with no solution .
  • I'd check your classpath, and ensure you only have one copy of each of the jars my hunch is you may have both old and new copies of at least one and that's confusing it .
  • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4 0" and put all as external jars on eclipse for my project, and copied it to WEB INF lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .
Summaries of the opinions about alfresco using Opinosis, an abstractive summarizer of opinions..
Summaries of the opinions about alfresco using contrastive viewpoints. Each entry contains a pair of positive and negative sentences that are most likely discussing about similar API features.
Summaries of opinions about based on specific API aspects, such as, performance, usability, etc. The 'Overview' page provides an overview of the aspects detected in the opinions. The 'Trend' page shows the distribution of polarity over time for each aspect. The 'Positive Opinions' page groups positive opinions by the detected aspects. The 'Contrastive By Aspect' page shows paris of contrastive opinions under each aspect (where found).
Security:
  • Everything else works fine (pngs, text, html, GET requests,even authentication).
  • N/A
Usability:
  • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that.
  • I'd check your classpath, and ensure you only have one copy of each of the jars - my hunch is you may have both old and new copies of at least one and that's confusing it.
Bug:
  • N/A
  • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4.0" and put all as external jars on eclipse for my project, and copied it to WEB-INF/lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that ...
Features:
  • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET_JAVA3 .
  • N/A
  • Security: 1
    1. general: 1
      • Everything else works fine (pngs, text, html, GET requests,even authentication).. details
  • Features: 1
    1. general: 1
      • BUT In BIRT Report in eclipse IDE no luck 1, in Scripted Data Source I put: CODESNIPPET_JAVA3 .. details
  • Usability: 6
    1. general: 6
      • @Gagravarr um, thank you, after i trying to find classes loaded, for some reason , JSONParser class not loaded, alfresco didn't see that.. details
      • and fetch rows in data set table like : CODESNIPPET_JAVA4 .. details
      • But still giving me white page with head titles only, empty cells !!.. details
      • I will talking throw codes line with a few words, In alfresco I need to create a reports using its Workflows APIs that response as JSON, I found the solution for using JSON as a Data Source in this link (this will be good reference to full understand my issue) : URL_http://www.birt-exchange.org/org/devshare/designing-birt-reports/1053 -scripted-data-source-using-json/ [ URL_http://www.birt-exchange.org/org/devshare /designing-birt-reports/1053-scripted-data-source-using-json/] I downloaded the source and I understand how its works, and finally I was having a problem "authentication issue" and solved it by editing source file 'JSONParser.java', anyway I have another problem now, I have the following code in Java thats working: CODESNIPPET_JAVA1 .. details
      • If I do a file POST however, the Alfresco server receives the file correctly and sends back a JSON response, but this time the response causes the browser to prompt for a download instead of the letting Javascript process the callback.. details
      • In both GET and POST responses the Content-Type is "application/json;charset=UTF-8" Many thanks for any responses.. details
  • Bug: 2
    1. general: 2
      • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4.0" and put all as external jars on eclipse for my project, and copied it to WEB-INF/lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .... details
      • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET_JAVA5 .. details
  • Usability: 4
    1. general: 4
      • I'd check your classpath, and ensure you only have one copy of each of the jars - my hunch is you may have both old and new copies of at least one and that's confusing it.. details
      • @Gagravarr I think all jars is copied, I downloaded "httpcomponents client 4.0" and put all as external jars on eclipse for my project, and copied it to WEB-INF/lib on alfresco (with JSONParser classes as a jar file), I forgot to put them first and I got Class Not Found Exception, but now you see my problem that I got after that .... details
      • To get exception I uploaded it to Alfresco integrated with BIRT, and I got : CODESNIPPET_JAVA5 .. details
      • Really I don't know what the problem is, and how to solve, if anybody have any idea for It, I spent about 1 week on it with no solution ... .. details